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1 Getting Started

Real-Time Windows Target Product Description
Run Simulink® models in real time on Microsoft® Windows® PCs

Real-Time Windows Target™ provides a real-time engine for executing
Simulink models on a Microsoft Windows PC and blocks that connect to a
range of I/O boards. It enables you to create and control a real-time system
for rapid prototyping or hardware-in-the-loop simulation.

Real-Time Windows Target supports two Simulink simulation modes: normal
mode, for simple real-time operation with access to I/O devices, and external
mode, for higher real-time performance (with Simulink Coder™).

Key Features

• Real-time closed-loop execution of Simulink models on Microsoft Windows

• Signal visualization and parameter tuning while model is running

• Execution control directly from Simulink, creating a PC-in-the-loop
prototyping environment

• Real-time performance exceeding 500 Hz in normal execution mode

• Real-time performance exceeding 5 kHz in external execution mode (with
Simulink Coder)

• Blocks supporting more than 250 I/O modules (including analog I/O,
digital I/O, counters, encoders, and frequency output) and communication
protocols (including UDP, serial, and CAN)
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Use the Product

Use the Product
After creating a model and simulating it using Simulink software in normal
mode, you can add Real-Time Windows Target I/O blocks representing
hardware. Depending upon the performance required, you can either simulate
again in Real-Time Windows Target normal mode or switch to external mode.

For external mode, you generate executable code with Simulink Coder and
the bundled C compiler, then run this target application in real time with
Simulink external mode.

Integration between Simulink external mode and Real-Time Windows Target
software allows you to use your Simulink model as a graphical user interface
for

• Signal visualization — Use the same Simulink Scope blocks that you use
to visualize signals during a non-real-time simulation to visualize signals
while running a real-time application.

• Parameter tuning — Use the Block Parameter dialog boxes to change
parameters in your application while it is running in real time.

Typical uses for Real-Time Windows Target applications include

• Real-time control — Create a prototype of automotive, computer
peripheral, and instrumentation control systems.

• Real-time hardware-in-the-loop simulation — Create a prototype of
controllers connected to a physical plant. For example, the physical plant
could be an automotive engine. Create a prototype of a plant connected to
an actual controller. For example, the prototyped plant could be an aircraft
engine.

• Education — Teach concepts and procedures for modeling, simulating,
testing real-time systems, and iterating designs.

1-3



1 Getting Started

Use This Guide
To benefit from this User’s Guide, you should be familiar with

• Using Simulink software and Stateflow® software to create models as block
diagrams, and simulating those models using Simulink software

• The concepts and use of Simulink Coder code generation software to create
executable code

When using Simulink Coder code generation software and Real-Time
Windows Target software, you do not need to program in C or other low-level
programming languages to create and test real-time systems.

If You Are a New User — Begin with “Run Real-Time Model” on page 3-13.

If You Are an Experienced User — Review the following sections:

• “Set Scope Parameters” on page 3-16

• “Set External Mode Scope Parameters” on page 3-19

• “Log Signals to MATLAB Workspace” on page 3-27

• “Log Signals to File” on page 3-34

After you are familiar with using Real-Time Windows Target software, read
how to add I/O driver blocks to your Simulink model in “Use I/O Driver
Blocks” on page 4-8.
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Features

In this section...

“Real-Time Kernel” on page 1-5

“Real-Time Application” on page 1-6

“Signal Acquisition and Analysis” on page 1-7

“Tune Parameters” on page 1-8

Real-Time Kernel
The Real-Time Windows Target software uses a small real-time kernel that
runs in Windows kernel mode using the built-in CPU clock as its primary
time source. In external mode, both the application and the I/O drivers run in
the kernel. In Simulink normal mode, only the I/O drivers run in the kernel.

• Timer interrupt — The kernel intercepts the interrupt from the CPU clock
before the Windows operating system receives it. The kernel then uses the
interrupt to trigger the execution of the compiled model. As a result, the
kernel is able to give the real-time application the highest priority available.

Note This behavior intercepts calls to the Windows operating system.
Consequently, you cannot use Win32 calls in your C-code S-function.
For more information, see “Incompatibility with Win32 API Calls” on page
A-4.

The kernel is provided as a Windows kernel-mode driver. To achieve more
accurate sampling, the kernel reprograms the CPU clock to a higher
frequency. Because the CPU clock is also the primary time source for
the Windows operating system, the kernel sends a timer interrupt to the
operating system at the original interrupt rate.

• Scheduler — The timer interrupt clocks a simple scheduler that runs
the executable. The number of tasks is equal to the number of sampling
periods in the model with multitasking mode. With single-tasking mode,
there is only one task. The maximum number of tasks is 32, and faster
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1 Getting Started

tasks have higher priorities than slower tasks. For example, a faster task
can interrupt a slower task.

During execution, the executable stores data in buffers. Later, the data in
these buffers is retrieved by the Scope block. The scheduling, data storing,
data transferring, and running the executable run in Windows kernel mode.

• Communication with hardware — The kernel interfaces and communicates
with I/O hardware using I/O driver blocks, and it checks that the I/O board
has been installed. If the board has been installed, the drivers allow your
real-time application to run.

You can choose to have a driver block use values equal to voltage, normalize
values from 0 to +1, normalize values from -1 to +1, or use the raw integer
values from the A/D or D/A conversion press. Drivers also run in Windows
kernel mode.

• Simulink normal mode — Communication between the Simulink
software algorithm and the real-time kernel is carried out by interprocess
communication.

• Simulink external mode — Communication between the Simulink software
and the real-time application is through the Simulink external mode
interface module. This module talks directly to the real-time kernel, and is
used to start the real-time application, change parameters, and retrieve
scope data.

Real-Time Application
The real-time application runs in real time on your host computer and has
the following characteristics:

• Compiled code — Created from the generated C-code using a bundled C
compiler shipped with the Real-Time Windows Target software. No other
third-party compiler is required or can be used.

Note The Real-Time Windows Target software uses the bundled compiler,
even if you have specified some other compiler using the mex -setup
command.
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• Relation to your Simulink model — The executable contains a binary
form of Simulink model components, connections between blocks, time
dependencies, and variables in the Simulink blocks.

• Relation to the kernel — The executable must be loaded and executed
directly by the Real-Time Windows Target kernel. It cannot be executed
without the kernel.

The kernel runs as a kernel-mode driver, intercepts timer interrupts from
the CPU clock, maintains clock signals for the Windows operating system,
and runs the application in real-time. As a result, both the kernel and the
real-time application run in Windows kernel mode.

• Checksum — The Simulink model and the executable contain a checksum
value. The kernel uses this checksum value to determine if the Simulink
model structure, at the time of code generation, is consistent with the
real-time application structure during execution. This verifies that
when you change parameters during an execution, the Simulink model
parameters map to the memory locations in the real-time application.

If you make structural changes to your Simulink model, the Simulink
checksum value will not match the executable checksum value. You will
have to rebuild your executable before you can connect it to your Simulink
model.

Signal Acquisition and Analysis
You can acquire, display, and save signals by using Simulink Scope blocks in
both Simulink normal and external mode. This lets you observe the behavior
of your model during a simulation or your application while it runs in real
time.

You can acquire signal data while running your real-time applications using

• Signal Tracing — Process of acquiring and visualizing signals during a
real-time run. It allows you to acquire signal data and visualize it on your
computer while the executable is running.

• Signal Logging — Process for acquiring signal data during a real-time run.
After the run reaches its final time or you manually stop the run, you can
plot and analyze the data.
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1 Getting Started

You can save (log) data to variables in the MATLAB® workspace or save
data to a MAT-file.

Signal logging differs from signal tracing. With signal logging you can only
look at a signal after a run is finished.

For more information, see “Log Signals to MATLAB Workspace” on page 3-27
and “Log Signals to File” on page 3-34.

Tune Parameters
Change the parameters in your Simulink model and observe the effect of those
changes during a simulation or while running an application in real time.

Simulink normal mode — You use your Simulink block diagram to access
block parameters just as you would in a Simulink model. Parameter changes
are propagated to the I/O drivers and from there to the hardware.

Simulink external mode — You use Simulink external mode to connect your
Simulink block diagram to your real-time application. The block diagram
becomes a graphical user interface (GUI) to that executable.

Simulink external mode allows you to change parameters by editing the block
diagram while running a simulation in external mode. New parameter values
are automatically transferred to the real-time application while it is running.

There are different types of model parameters that you can change while
running your real-time application. For example, parameters include the
amplitude of a gain and the frequency of a sine wave. After you connect your
real-time application to your Simulink model, you can change parameters.
You can change these parameters before or while your real-time application
is running by using one of the following methods:

• Block parameters — Change values in the dialog boxes associated with
the Simulink blocks.

• Block parameters for masked subsystems — Change values in user-created
dialog boxes associated with a subsystem.
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• MATLAB variables — Create MATLAB variables that represent Simulink
block parameters, and then change parameter values by entering the
changes through the MATLAB command line.

For more information about parameter tuning, see “Tune Parameters” on
page 3-43.
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1 Getting Started

Hardware Environment

In this section...

“PC-Compatible Computer” on page 1-10

“Input/Output Driver Support” on page 1-10

PC-Compatible Computer
You can use a PC-compatible computer that runs Windows XP, Windows
Vista™, or Microsoft Windows 7.

Your computer can be a desktop, laptop, or notebook computer.

Input/Output Driver Support
Real-Time Windows Target applications use standard and inexpensive I/O
boards for PC-compatible computers. When running your models in real
time, Real-Time Windows Target software captures the sampled data from
one or more input channels, uses the data as inputs to your block diagram
model, immediately processes the data, and sends it back to the outside world
through an output channel on your I/O board.

I/O Boards
I/O boards — Real-Time Windows Target software supports a wide range of
I/O boards. Some of the capabilities on a board may not be supported by
Real-Time Windows Target software. Check Supported I/O Boards on the
MathWorks® Web site for an updated list of supported boards and capabilities.

I/O Driver Block Library
Real-Time Windows Target software provides a custom Simulink block
library. The I/O driver block library contains universal drivers for supported
I/O boards. These universal blocks are configured to operate with the library
of supported drivers. This allows easy location of driver blocks and easy
configuration of I/O boards.

You drag and drop a universal I/O driver block from the I/O library the same
way as you would from a standard Simulink block library. And you connect
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an I/O driver block to your model just as you would connect a standard
Simulink block.

You create a real-time application in the same way that you create a Simulink
model, by using standard blocks and C-code S-functions. You can add input
and output devices to your Simulink model by using the I/O driver blocks from
the rtwinlib library provided with the Real-Time Windows Target software.
This library contains the following blocks:

• Analog Input

• Analog Output

• Counter Input

• Digital Input

• Digital Output

• Encoder Input

• Frequency Output

• Other Input

• Other Output

• Packet Input

• Packet Output

• Real-Time Sync

• Stream Input

• Stream Output

The Real-Time Windows Target software provides driver blocks for more
than 200 I/O boards. These driver blocks connect the physical world to your
real-time application:

• Sensors and actuators are connected to I/O boards.

• I/O boards convert voltages to numerical values and numerical values to
voltages.

• Numerical values are read from or written to I/O boards by the I/O drivers.
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1 Getting Started

Software Environment

In this section...

“Non-Real-Time Simulation” on page 1-12

“Normal Mode Real-Time Simulation” on page 1-12

“External Mode Real-Time Execution” on page 1-13

“Development Process” on page 1-13

Non-Real-Time Simulation
You create a Simulink model and use Simulink software in normal mode for
non-real-time simulation on your host computer.

• Simulink model — Create block diagrams with Simulink software by using
simple drag-and-drop operations, and then enter values for the block
parameters and select a sample rate.

• Non-real-time simulation — Simulink software uses a computed time
vector to step your Simulink model. After the outputs are computed
for a given time value, the Simulink software immediately repeats the
computations for the next time value. This process is repeated until it
reaches the stop time.

Because this computed time vector is not connected to a hardware clock, the
outputs are calculated in nonreal time as fast as your computer can run. The
time to run a simulation can differ significantly from real time.

Normal Mode Real-Time Simulation
For real-time simulation on your host computer, you can run your Real-Time
Windows Target model under normal mode. In normal mode, Simulink runs
the simulation algorithm and the real-time kernel runs the I/O drivers in a
Windows kernel mode process.

In this mode, you can use either a variable-step or a fixed-step algorithm.
For each simulation step, Simulink evaluates the blocks in the model.
When Simulink runs a Real-Time Windows Target block, the block not only
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communicates signal values to and from the I/O hardware, it synchronizes the
simulation with the real-time clock.

Because only the I/O drivers are synchronized with the real-time clock, the
simulation might miss clock ticks. You can set I/O block parameters to handle
a specified number of missed ticks.

External Mode Real-Time Execution
For higher-performance real-time execution on your host computer, create a
real-time application and use Simulink external mode, Simulink Coder code
generation software, Real-Time Windows Target software, and the bundled
C compiler, to produce an executable that the kernel can run in real time.
This real-time application uses the initial parameters available from your
Simulink model at the time of code generation.

If you use continuous-time components in your model and create code
with Simulink Coder code generation software, you must use a fixed-step
integration algorithm. Real-Time Windows Target software provides the
capabilities required to use the real-time resources on your computer
hardware. Based on your selected sample rate, Real-Time Windows Target
software uses interrupts to step your application in real time at the specified
rate. With each new interrupt, the executable computes the block outputs
from your model.

Development Process
With Real-Time Windows Target rapid prototyping software, you can use
your desktop computer with the MATLAB environment, Simulink software,
Simulink Coder code generation software, and Real-Time Windows Target
software to:

1 Design a control system — Use the MATLAB environment and Control
System Toolbox™ software to design and select the system coefficients for
your controller.

2 Create a Simulink model — Use Simulink blocks to graphically model
your physical system.
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3 Run a simulation in nonreal time — Check the behavior of your model
before you create a real-time application. For example, you can check the
stability of your model.

4 Run a normal mode simulation in real-time—Check the behavior of your
model in real time with reduced performance before doing code generation.
For example, you can check your model at low sample rates before moving
to high sample rates.

Tip To run a non-real-time normal mode model in real-time normal mode,
you must:

• Add one or more configured Real-Time Windows Target blocks to the
model.

• Install the real-time kernel (see “Install the Kernel Using MATLAB”
on page 2-7).

5 Create a real-time application — Simulink Coder code generation software
creates C code from your Simulink model. The bundled C compiler compiles
the C code to an executable that runs with the Real-Time Windows Target
kernel.

6 Run an application in real time — Your desktop computer is the target
computer to run the real-time application.

7 Analyze and visualize signal data — Use MATLAB functions to plot data
saved to the MATLAB workspace or a disk.

Note Although Real-Time Windows Target applications run on the same
hardware as Windows, the Real-Time Windows Target kernel and the Win32
kernel are incompatible. When a Real-Time Windows Target application
includes externally created code, such as a custom I/O driver block or a
user-supplied S-function, the code cannot access any Win32 function. For
more information, see “Incompatibility with Win32 API Calls” on page A-4.
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Real-Time Execution in Normal Mode
Real-Time Windows Target extends Simulink normal mode to run in real time.

The simulation algorithm for a Simulink normal mode model runs entirely
within Simulink. The model can use either a fixed-step or a variable-step
solver and runs as fast as it can, given the presence of competing Windows
processes. However, it is not synchronized with a real-time clock and cannot
easily be used to operate real-time hardware.

Simulink 
Process

Non-Real-Time Normal Mode Execution

You can synchronize a Simulink model with a real-time clock using Real-Time
Windows Target I/O blocks. In real-time normal mode, Simulink executes the
simulation algorithm, while a separate Windows kernel mode process runs I/O
drivers for the I/O blocks. Both the Simulink process and the Windows kernel
mode process run on the host machine, using a shared memory interface
to transfer parameter data.

• Signal acquisition — You can capture and display signals from your
real-time application while it is running. Simulink retrieves signal data
from the I/O driver and displays it in the same Scope blocks you used for
simulating your model in nonreal time.
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• Parameter tuning — You can change parameters in your Simulink block
diagram and have the new parameters take effect in your Simulink model
in real time. The effects then propagate through the I/O driver to the
hardware.

Real-Time Windows Target Normal Mode Execution

Windows Kernel 
Mode ProcessI/O Driver

Normal
Mode

Simulink 
Process

Because only the I/O drivers are synchronized with the real-time clock,
Simulink can use either a fixed-step or a variable-step solver. The Sample
Time setting in the Real-Time Windows Target block does not change the
step size of the simulation. For a fixed-step simulation, the step size is set
in the Fixed step size box from the Configuration Parameters dialog box.
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For a variable-step simulation, the step size is determined automatically by
Simulink or by the Min Step Size attribute.

In real-time normal mode, at each sample interval Simulink evaluates each
real-time block and writes the input data into a buffer it passes to the
Windows kernel mode process. The kernel mode process propagates the data
to the hardware, which writes response data into another buffer. At the next
time tick, Simulink reads the response data and propagates it to the rest
of the model.

A consequence of this kind of limited synchronization is that your simulation
can be configured to miss real-time clock ticks and their associated data
points. Ticks can be missed under the following circumstances:

• Complexity of Model — The model might be so complex that Simulink
cannot keep up with the real-time kernel. In this case, the number of
missed ticks increases steadily with time. Once the number of missed ticks
exceeds Maximum Missed Ticks, an error occurs, even if Maximum
Missed Ticks is set to a large value. This situation is marked by a rising
straight line on a Scope connected to the optional Missed Ticks port.

• Process Contention — The model generally executes faster than required to
keep up with the kernel, but process contention or some random operating
system condition prevents Simulink from executing the model over some
time period. In this case, the number of missed ticks jumps to some
number, then decreases to zero as Simulink catches up with the kernel.
This situation is marked by a sawtooth-like shape on a Scope connected
to the Missed Ticks port.

• Variable-Step Solver — If you are using a variable-step solver, the number
of ticks per algorithm step may vary during simulation. If Simulink
execution does not reach the Real-Time Sync or I/O blocks in time to
synchronize with the tick, the number of missed ticks jumps to some
number, then decreases to zero as Simulink catches up with the kernel. As
with process contention, this situation is marked by a sawtooth-like shape
on a Scope connected to the Missed Ticks port.
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Real-Time Execution in External Mode
A higher-performance alternative to real-time normal mode is real-time
external mode. In this mode, you use Simulink Coder to dynamically link
generated algorithm code with I/O driver code generated from the I/O blocks.
The resulting executable runs in Windows kernel mode on the host computer
and exchanges parameter data with Simulink via a shared memory interface.

• Signal acquisition — You can capture and display signals from your
real-time application while it is running. Signal data is retrieved from the
real-time application and displayed in the same Simulink Scope blocks
you used for simulating your model.

• Parameter tuning — You can change parameters in your Simulink block
diagram and have the new parameters passed automatically to the
real-time application. Simulink external mode changes parameters in your
real-time application while it is running in real time.

The external mode executable is fully synchronized with the real-time clock.
The main role of Simulink is to read and display simulation results returned
from the executable.

Note You must use a fixed-step solver in external mode.
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Simulink 
Process

Real-Time Windows Target External Mode Execution

Windows Kernel 
Mode Process

Real-Time Windows
Target Executable

I/O Driver

In external mode, the real-time application runs in the Windows kernel
mode process. Using I/O drivers running in that process to communicate
with the hardware, it stores contiguous response data in memory accessible
to Simulink until a data buffer is filled. When the buffer is filled, the
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real-time application continues to run while Simulink transfers the data to
the MATLAB environment through Simulink external mode. Transfer of
data is less critical than maintaining deterministic real-time updates at the
selected sample interval. Therefore, data transfer runs at a lower priority
in the remaining CPU time after model computations are performed while
waiting for another interrupt to trigger the next model update.

Data captured within one buffer is contiguous. When a buffer of data has
been transferred, it is immediately plotted in a Simulink Scope block, or it
can be saved directly to a MAT-file using the data archiving feature of the
Simulink external mode.

With data archiving, each buffer of data can be saved to its own MAT-file. The
MAT-file names can be automatically incremented, allowing you to capture
and automatically store many data buffers. Although points within a buffer
are contiguous, the time required to transfer data back to Simulink forces an
intermission for data collection until the entire buffer has been transferred
and may result in lost sample points between data buffers.
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Software Components and Installed Files
Real-Time Windows Target is a self-targeting rapid prototyping system where
the host and the target computer are the same computer.

MATLAB Environment
The MATLAB environment provides the design and data analysis tools that
you use when creating and testing Simulink models. In particular, see:

• “Importing and Exporting Data”

• “Plotting Data”

Simulink Software
Simulink software provides an environment where you model your physical
system and controller as a block diagram. You create the block diagram by
using a mouse to connect blocks and a keyboard to edit block parameters. C
code S-functions are supported by Simulink Coder code generation software.

With Real-Time Windows Target software, you can remove the physical
system model and replace it with Real-Time Windows Target I/O driver blocks
connected to your sensors and actuators. The Real-Time Windows Target I/O
library supports more than 200 boards.

Note Some of the functions on a board may not be supported by Real-Time
Windows Target software. Check the MathWorks Web site for an updated list
of supported boards and functions at Supported I/O Boards.

Known limitations include:

• Unsupported Simulink products — The Real-Time Windows Target
software does not support the Simscape™ or SimDriveline™ products.

• Unsupported Simulink blocks in external mode — You can use Real-Time
Windows Target software with most Simulink blocks, including
discrete-time and continuous-time systems. In external mode, Real-Time
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Windows Target software does not support blocks that do not run in real
time, nor does it support To File blocks.

• Limitations with Simulink Coder code generation software:

- When you use a continuous-time system and generate code for external
mode execution with Simulink Coder code generation software, you must
use a fixed-step integration algorithm.

- The Simulink Coder product provides an API for the MATLAB
Distributed Computing Server™ or Parallel Computing Toolbox™
products to perform parallel builds that reduce build time for referenced
models. However, this API does not support parallel builds for models
whose system target file parameter is set to rtwin.tlc or rtwinert.tlc. In
other words, you cannot perform parallel builds for Real-Time Windows
Target.

- MATLAB S-functions are not supported in external mode.

Simulink Coder Software
Simulink Coder code generation software provides the utilities to convert
your Simulink models into C code and then compile the code into a real-time
executable.

Note

• Simulink Coder is required for External Mode.

• Compiler support is included as part of the product installation. No
additional or external compiler is required.

• MATLAB Coder is required for Simulink Coder installation.

Real-Time Windows Target software is designed for maximum flexibility
during rapid prototyping. This flexibility allows parameter tuning and signal
tracing during a real-time run, but increases the size of the generated code.
However, Simulink Coder code generation software provides other code
formats that generate more compact code for embedded applications.
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Installed Files
You can install Real-Time Windows Target software as part of the regular
installation process documented in MathWorks installation documentation.
This section describes installed files that are unique to Real-Time Windows
Target software. When using the product, you may find it helpful to know
where these files are located.

• MATLAB working folder — Simulink models (model) and the Real-Time
Windows Target executable (model.rwd).

Note Select a working folder outside the MATLAB root. See “Initial
Working Folder” on page 2-5.

• Simulink Coder project folder — The Simulink Coder C-code files (model.c,
model.h) are in a subfolder called model_rtwin.

• Real-Time Windows Target Files — The files included with Real-Time
Windows Target software are located in the folder

matlabroot\toolbox\rtw\targets\rtwin

Real-Time Windows Target software provides files to help Simulink Coder
code generation software create C code from your Simulink model and compile
that code to a real-time executable:

• System Target File (rtwin.tlc) — Defines the process of generating C code
by Real-Time Windows Target software.

• Template Makefile and Makefile (rtwin.tmf, model_name.mk) — The
template makefile serves as a template for generating the real makefile,
which the make utility uses during model compilation. During the
automatic build procedure, the make command extracts information
from the template makefile rtwintmf.m and generates the makefile
model_name.mk.

• Make Command (make_rtw.m) — The standard make command supplied
with Simulink Coder code generation software.

Other files provided with Real-Time Windows Target software include
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• I/O drivers (*.rwd) — Binaries for I/O device drivers. Real-Time Windows
Target software does not link the driver object files with your real-time
executable. The drivers are loaded into memory and run by the kernel
separately.

• Simulink external mode interface (rtwinext.mex*) — MEX-file for
communicating between Simulink external mode and the Real-Time
Windows Target kernel.

Simulink external mode uses the MEX-file interface module to download
new parameter values to the real-time model and to retrieve signals from
the real-time model. You can display these signals in Simulink Scope
blocks.

• Kernel install and uninstall commands (rtwintgt.m, rtwho.m) — .m
scripts to install and uninstall the Real-Time Windows Target kernel and
check installation.

Initial Working Folder
Set your MATLAB working folder outside the MATLAB root folder. The
default MATLAB root folder is c:\matlabN, where N is the MATLAB version
number.

Set the Working Folder from the Desktop Icon
Your initial working folder is specified in the shortcut file you use to start
the MATLAB environment. To change this initial folder, use the following
procedure:

1 Right-click the MATLAB desktop icon, or from the program menu,
right-click the MATLAB shortcut.

2 Click Properties. In the Start in text box, enter the folder path you want
the MATLAB environment to use initially outside the MATLAB root folder.

3 Click OK, and then start the MATLAB environment. To check your
working folder, type pwd or cd.

Set the Working Folder from the MATLAB Environment
Use the following procedure as an alternative, but temporary, procedure for
setting your MATLAB working folder:
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1 In the MATLAB Command Window, type cd c:\mwd.

2 Check the current working folder, type pwd or cd.

The MATLAB Command Window displays

ans = c:\mwd or c:\mwd
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Install Real-Time Kernel
The Real-Time Windows Target software requires a real-time kernel that
interfaces with the Windows operating system. The Real-Time Windows
Target kernel assigns the highest priority of execution to your real-time
executable, which allows it to run without interference at the selected sample
rate. During real-time execution of your model, the kernel intervenes to
give the model priority to use the CPU to execute each model update at the
prescribed sample times. Once a model update completes, the kernel releases
the CPU to run other Windows based applications that might need servicing.

In this section...

“Install the Kernel Using MATLAB” on page 2-7

“Uninstall the Kernel” on page 2-8

Install the Kernel Using MATLAB
You must install the kernel before you can run a Real-Time Windows Target
application. During software installation, the Real-Time Windows Target
software is copied onto your hard drive, but the Real-Time Windows Target
kernel is not automatically installed into the operating system.

Installing the kernel configures it to start running in the background each
time you start your computer. The following procedure describes how to use
the command rtwintgt -install. (You can also use the command rtwintgt
-setup instead.) To install the kernel:

1 In the MATLAB Command Window, type:

rtwintgt -install

The MATLAB Command Window displays one of these messages:

You are going to install the Real-Time Windows Target kernel.

Do you want to proceed? [y] :

or:

There is a different version of the Real-Time Windows Target kernel installed.
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Do you want to update to the current version? [y] :

2 Type y to continue installing the kernel, or n to cancel installation without
making changes.

If you type y, the MATLAB environment installs the kernel and displays
the message:

The Real-Time Windows Target kernel has been successfully installed.

3 If a message appears asking you to restart your computer, do so before
attempting to use the kernel, or your Real-Time Windows Target model
will not run.

4 After installing the kernel, verify that it was installed by typing:

rtwho

The MATLAB Command Window should display a message that shows the
kernel version number, followed by timer, driver, and other information.

Once the kernel is installed, you can leave it installed. The kernel remains
idle after you have installed it, which allows the Windows operating system
to control the execution of standard Windows based applications, such as
Internet browsers, word processors, the MATLAB environment, and so on.
The kernel becomes active when you begin execution of your model, and
becomes idle again after model execution completes.

Uninstall the Kernel
If you encounter problems with Real-Time Windows Target software, you
can uninstall the kernel. Once uninstalled, the kernel is no longer active.
The kernel executable file remains on your hard drive so that you can later
reinstall it.

Uninstall the Kernel Using MATLAB
To uninstall the kernel from MATLAB:

1 In the MATLAB Command Window, type:

rtwintgt -uninstall
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The MATLAB Command Window displays the message:

You are going to uninstall the Real-Time Windows Target kernel.

Do you want to proceed? [y]:

2 Type y to continue uninstalling the kernel, or n to cancel uninstallation
without making changes.

If you type y, the MATLAB environment uninstalls the kernel by removing
it from memory, then displays the message:

The Real-Time Windows Target kernel has been successfully uninstalled.

3 After uninstalling the kernel, verify that it was uninstalled. Type:

rtwho

The MATLAB Command Window displays the message:

Real-Time Windows Target installation is not complete.
Please type 'rtwintgt -setup' to complete the installation.
Type 'help rtwintgt' for more information.

Uninstall the Kernel Using Host Computer Command Line
Uninstalling the MATLAB environment does not uninstall the Real-Time
Windows Target kernel. If you have uninstalled the MATLAB environment
and need to uninstall the kernel, launch a DOS command shell and type:

rtwintgt -uninstall

The rtwintgt program uninstalls the kernel by removing it from memory,
then displays the message:

The Real-Time Windows Target kernel uninstalled successfully.
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Run Confidence Test
Real-Time Windows Target includes several example models you can use to
test your installation. These models are preconfigured with settings such as
target and scope settings, sample time, and integration algorithm. To see
these models, type rtwtdemo in the MATLAB Command Window.

Tip You can run examples in both Simulink Normal Mode (initial setting)
and in Simulink External Mode.

Once you have finished installing the Real-Time Windows Target software
and kernel, you should test the installation by running the model rtvdp.
If you change your installation, you should repeat this test to confirm
that the Real-Time Windows Target software is still working. To open
the example model, type rtvdp in the MATLAB Command Window, or
launch MATLAB Help, open Real-Time Windows Target, and choose
Examples > Real-Time Van der Pol Simulation.

In this section...

“Run the Model rtvdp” on page 2-10

“Display Status Information” on page 2-13

“Examples Library” on page 2-13

Run the Model rtvdp
The model rtvdp does not have I/O blocks, so that you can run this model
regardless of the I/O boards in your computer. Running this model will test the
installation by running Simulink Coder code generation software, Real-Time
Windows Target software, and the Real-Time Windows Target kernel.

After you have installed the Real-Time Windows Target kernel, you can test
the entire installation by building and running a real-time application. The
Real-Time Windows Target software includes the model rtvdp, which already
has Simulink Coder options selected for you:

1 In the MATLAB Command Window, type
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rtvdp

The Simulink model rtvdp window opens.

2 Double click Switch To External Mode on the model.

Tip The model is initially in normal mode. At this point, you might start
real-time normal mode simulation by clicking Simulation > Run.

3 From the Code menu, click C/C++ Code > Build Model

The MATLAB Command Window displays the following messages:

### Starting build procedure for model: rtvdp

### Generating code into build folder: C:\Work\rtvdp_rtwin

### Invoking Target Language Compiler on rtvdp.rtw

. . .

### Successful completion of build procedure for model: rtvdp

2-11



2 Installation and Configuration

4 Click Simulation > Connect To Target or click the Connect To Target

button on the toolbar,

The MATLAB Command Window displays the following message:

Model rtvdp loaded

5 Click Simulation > Run or click the Run button on the toolbar.

The target application begins running.

6 From Simulation menu, click Stop Real-Time Code.

The real-time application stops running, and the Scope window stops
displaying the output signals.
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Display Status Information
The Real-Time Windows Target software provides the command rtwho for
displaying the kernel version number, followed by timer, driver, and other
information. To see this information, in the MATLAB Command Window type

rtwho

The command displays several lines of information in the MATLAB Command
Window. Some possible lines and their interpretations are:

TIMERS: Number Period Running
1 0.01 Yes

The indicated timer(s) exist on your system with the period and run status
shown for each timer.

DRIVERS: Name Address Parameters
Humusoft AD512 0x300 []

ecg 0 []

The indicated device driver(s) are installed on your system at the address and
with the parameter(s) shown for each driver.

Examples Library
The examples library includes models with preset values and dialog boxes.
These models include simple signal processing and simple control examples
that use no I/O blocks, use A/D blocks only, and use both A/D and D/A blocks.

Tip

• To run an example that uses I/O blocks, you must configure the Adapter
block to match the I/O board installed in your computer.

• You can run examples in both Simulink Normal Mode (initial setting) and
in Simulink External Mode.

To see these models from the MATLAB environment:
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1 Type rtwtdemo in the MATLAB Command Window.

The Real-Time Windows Target Demos window displays.

2 From the list, select the example to open it.
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Use Simulink Models
A Simulink model is a graphical representation of your physical system. You
create a Simulink model for a non-real-time simulation of your system, and
then you use the Simulink model to create a real-time application.

In this section...

“Create a Model” on page 3-2

“Configure a Model” on page 3-6

“Run Simulation” on page 3-11

Create a Model
You need to create a Simulink model before you can run a simulation or
create a real-time application. This procedure explains how to create a
simple Simulink model. You can use this model as an example to learn other
procedures that are useful with Real-Time Windows Target software.

1 In the MATLAB Command Window, type

simulink

The Simulink Library Browser opens. The left pane shows a hierarchy of
libraries and block categories, with the Simulink library at the top. The
right pane shows the blocks available in the category selected on the left.

2 Choose File > New >Model, or click theNewmodel button on the toolbar.

An empty Simulink window opens.

3 In the left pane of the Simulink Library Browser window, select Simulink
> Sources. Click and drag a Signal Generator block from the browser to
the Simulink window.

Select Continuous. Click and drag a Transfer Fcn block to the Simulink
window.

Select Sinks. Click and drag a Scope block to the Simulink window.

3-2



Use Simulink® Models

4 Connect the Signal Generator output to the Transfer Fcn input by
clicking-and-dragging a line between the blocks. Likewise, connect the
Transfer Fcn output to the Scope input.

5 Double-click the Transfer Fcn block. The Block Parameters dialog box
opens. In the Numerator text box, enter:

[10000]

In the Denominator text box, enter

[1 70 10000]

Your Block Parameters dialog box looks like this:

6 Click OK.

3-3



3 Basic Procedures

7 Double-click the Signal Generator block. The Block Parameters dialog box
opens. From the Wave form list, select square.

In the Amplitude text box, enter

1

In the Frequency text box, enter

20

From the Units list, select rad/sec.

Your Block Parameters dialog box looks like this:

8 Click OK.

The completed Simulink block diagram looks like this, with toolbar and
status bar not shown:
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9 From the File menu, click Save As. The Save As dialog box opens. In the
File name text box, enter a file name for your Simulink model and click
Save. For example, type

rtwin_model

The Simulink software saves your model in the file rtwin_model.

To specify a default Real-Time Windows Target configuration set for your
model, see “Specify a Default Configuration Set” on page 3-6. If you activate
this configuration set for your model, you can build your real-time application
later without setting additional configuration parameters.

To manually configure your model, continue to “Enter Configuration
Parameters Manually” on page 3-8, following. That section teaches you how
to enter configuration parameters for your Simulink model, then leads you
into procedures for entering scope parameters and running a non-real-time
simulation of the model.

Reference a Model
The Real-Time Windows Target software supports model referencing. See
“Overview of Model Referencing”.

File System Input/Output
When run in external mode, the Real-Time Windows Target software does
not include a file system. Therefore, a Simulink model intended for use in a
Real-Time Windows Target application cannot use blocks, such as the To File
or From File block, that generate file I/O calls such as fopen or fprintf.

If a Real-Time Windows Target model contains a block that tries to perform
file system I/O, an error could occur when you try to compile the model,
generate code for it, or use external mode with it. Even if no error occurs, the
block has no effect on either simulation or code execution.
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You can use file I/O blocks in Simulink normal mode simulation in real time.
In this case, the file I/O is not carried out by the real-time kernel, but by
Simulink itself. To access files, use the Packet Input, Packet Output, Stream
Input, or Stream Output blocks and select the driver Standard Devices >
File.

To log signal data without needing a file system, use the techniques described
in “Log Signals to File” on page 3-34. See “Run Application from Simulink” on
page 3-22 for information about using external mode to execute a Real-Time
Windows Target application.

Configure a Model
After you create a Simulink model, you can enter configuration parameters
for the model. These parameters control many properties of the model
for simulation and code generation. This section contains the essential
information you need when setting configuration parameters for a Real-Time
Windows Target application. For information about Simulink configuration ,
see “Manage a Configuration Set”.

A configuration set is a named set of values for model parameters, such as
solver type and simulation start or stop time. Every new model is created
with a default configuration set, called Configuration, that initially specifies
default values for the model’s model parameters. You can subsequently create
additional configuration sets and associate them with the model, as described
in “Manage a Configuration Reference”.

The easiest way to specify configuration parameters for a Real-Time Windows
Target model is to programmatically assign the default Real-Time Windows
Target configuration set, as described in “Specify a Default Configuration Set”
on page 3-6. You can also set parameters manually, as described in “Enter
Configuration Parameters Manually” on page 3-8. Other sections describe
setting configuration patterns for specific purposes.

Specify a Default Configuration Set
After you create a Simulink model, you can use the rtwinconfigset function
to specify a default Real-Time Windows Target configuration set for the
model. In most cases, using rtwinconfigset provides the configuration
parameter values that the model needs. The following procedure uses the
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Simulink model rtwin_model as an example and assumes you have already
loaded that model (see “Create a Model” on page 3-2):

1 If you have not already saved the model, from the File menu, click Save
As. The Save As dialog box opens. In the File name text box, enter a file
name for your Simulink model and click Save. For example, type

rtwin_model

The Simulink software saves your model in the file rtwin_model.

2 In the MATLAB Command Window, type

rtwinconfigset('rtwin_model')

The default Real-Time Windows Target configuration set, RTWin, is now
active for the rtwin_model model. (Alternatively, you can set the default
Real-Time Windows Target configuration set by setting the Configuration
Parameters System target file option to rtwin.tlc.) You do not need to
perform other configuration for a Real-Time Windows Target application.

3 Save the model.

See “Create Real-Time Application” on page 3-18 for a description of how to
build your Real-Time Windows Target application.

To revert to the default configuration set, Configuration, or other configuration
set you have for the model, use Model Explorer. This is an alternative tool
that you can use to enter simulation parameters for a model. See the Simulink
documentation for a description of how to use Model Explorer.

Note Your model uses a Real-Time Windows Target configuration set when
you change the System target file value to a Real-Time Windows Target
one, such as rtwin.tlc or rtwinert.tlc. The software creates the Real-Time
Windows Target configuration set, RTWin or RTWinERT, only if one does
not already exist.
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Enter Configuration Parameters Manually
The configuration parameters give information to Simulink software for
running a simulation. This procedure uses the Simulink model rtwin_model
as an example and assumes you have already loaded that model:

1 In the Simulink window, and from the Simulation menu, click Model
Configuration Parameters. In the Configuration Parameters dialog
box, click the Solver tab.

The Solver pane opens.

2 In the Start time field, enter 0.0. In the Stop time field, enter the amount
of time you want your model to run. For example, enter 10.0 seconds.

3 From the Type list, choose Fixed-step. Simulink Coder code generation
software does not support variable step solvers.

4 From the Solver list, choose a solver. For example, choose the general
purpose solver ode5 (Dormand-Prince).

5 In the Fixed step size field, enter a sample time. For example, enter
0.001 seconds for a sample rate of 1000 samples/second.

6 From the Tasking Mode list, choose SingleTasking. (For models with
blocks that have different sample times, choose MultiTasking.)

Your Solver pane looks like this:
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7 Do one of the following:

• Click Apply to apply the changes to your model and leave the dialog
box open.

• Click OK to apply the changes to your model and close the dialog box.

Enter Scope Parameters for Signal Tracing
You enter or change scope parameters to specify the x-axis and y-axis in a
Scope window. Other properties include the number of graphs in one Scope
window and the sample time for models with discrete blocks.

After you add a Scope block to your Simulink model, you can enter the scope
parameters for signal tracing:

1 In the Simulink window, double-click the Scope block.

A Scope window opens.

2 Click the Parameters button on the toolbar.
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A Scope parameters dialog box opens.

3 Click the General tab. In the Number of axes field, enter the number of
graphs you want in one Scope window. For example, enter 1 for a single
graph. Do not select the Floating scope check box.

In the Time range field, enter the upper value for the time range. For
example, enter 1 second. From the Tick labels list, choose all.

From the Sampling list, choose Sample time and enter 0 in the text box.
Entering 0 indicates that the Simulink software evaluates this block as a
continuous time block. If you have discrete blocks in your model, enter the
Fixed step size you entered in the Configuration Parameters dialog box.

Your Scope parameters dialog box looks like this:

4 Do one of the following:

• Click Apply to apply the changes to your model and leave the dialog
box open.

• Click OK to apply the changes to your model and close the dialog box.

5 In the Scope window, point to the y-axis and right-click.

6 From the pop-up menu, click Axes Properties.
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7 The Scope properties: axis 1 dialog box opens. In the Y-min and Y-max
text boxes, enter the range for the y-axis in the Scope window. For example,
enter -2 and 2.

Your Scope axis dialog box looks like this:

8 Do one of the following:

• Click Apply to apply the changes to your model and leave the dialog
box open.

• Click OK to apply the changes to your model and close the dialog box.

Run Simulation
You use Simulink normal mode to run a non-real-time simulation. Running a
simulation lets you observe the behavior of your model in nonreal time.

After you load your Simulink model into the MATLAB workspace, you can
run a simulation. This procedure uses the Simulink model rtwin_model as an
example and assumes you have loaded that model:

1 In the Simulink window, double-click the Scope block.

The Simulink software opens a Scope window with an empty graph.

2 Select Simulation > Mode > Normal.

3 Select Simulation > Run to begin simulation or click the Run

button on the toolbar.

3-11



3 Basic Procedures

The Simulink software runs the simulation and plots the signal data in
the Scope window.

During the simulation, the Scope window displays the samples for one
time range, increases the time offset, and then displays the samples for
the next time range.

4 Do one of the following:

• Let the simulation run to the stop time.

• From the Simulation menu, click Stop.

The simulation stops.
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Run Real-Time Model

In this section...

“Set External Mode Code Generation Parameters” on page 3-14

“Set Scope Parameters” on page 3-16

“Create Real-Time Application” on page 3-18

“Set External Mode Scope Parameters” on page 3-19

“Run Application from Simulink” on page 3-22

“Run Application from MATLAB Command Line” on page 3-25
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Set External Mode Code Generation Parameters
After you create a Simulink model, you can enter simulation parameters
for use by Simulink Coder code generation software for creating C code and
building a real-time application.

This procedure uses the Simulink model rtwin_model as an example and
assumes you have already loaded that model:

1 In the Simulink window, and from the Simulation menu, click Model
Configuration Parameters.

2 Click the Code Generation node.

The Code Generation pane opens.

3 In the Target selection section, click the Browse button at the System
target file list.

The System Target File Browser opens.

4 Select the system target file for building a Real-Time Windows Target
application, rtwin.tlc, and click OK.

The dialog automatically enters the system target file rtwin.tlc, the
template makefile rtwin.tmf, and the make command make_rtw into the
Code Generation pane.

If you have the Embedded Coder® product, you can build an ERT target
application. To build an ERT target application, in the Target selection
section, click the Browse button at the System target file list. Click
rtwinert.tlc, and then click OK.

Although not visible in the Code Generation pane, when you click OK
you also configure the external target interface MEX file rtwinext. This
allows external mode to pass new parameters to the real-time application
and to return signal data from the real-time application. The data is
displayed in Scope blocks or saved with signal logging.

Your Code Generation pane looks like this:
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Do not select Inline parameters on the Signals and Parameters node
under Optimization. Inlining parameters is used for custom targets when
you want to reduce the amount of RAM or ROM with embedded systems.
Also, if you select inlining parameters, you disable the parameter tuning
feature. Since PCs have more memory than embedded systems, you should
not inline parameters.

5 Click the Hardware Implementation node. The following values are
set by default:

• Device vendor — Generic

• Device type — 32-bit x86 compatible

• Test hardware is the same as production hardware— Selected

Your Hardware Implementation pane looks like this:
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6 Do one of the following:

• Click Apply to apply the changes to your model and leave the dialog
box open.

• Click OK to apply the changes to your model and close the dialog box.

Set Scope Parameters
You enter or change scope parameters to format the x-axis and y-axis in a
Scope window. Other parameters include the number of graphs in a one Scope
window and whether the scope is connected to a continuous or discrete model.

If you entered the scope parameters for running a simulation, you can
skip this procedure. This information is repeated here if you did not run a
simulation. This procedure is the same for normal mode and external mode.

After you add a Scope block to your Simulink model, you can enter the scope
parameters for signal tracing:
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1 In the Simulink window, double-click the Scope block.

A Scope window opens.

2 Click the Parameters button on the toolbar.

A Scope parameters dialog box opens.

3 Click the General tab. In the Number of axes field, enter the number of
graphs you want in one Scope window. For example, enter 1 for a single
graph. Do not select the floating scope check box.

In the Time range field, enter the upper value for the time range. For
example, enter 1 second. From the Tick labels list, choose all.

From the Sampling list, choose Sample time and enter 0 in the text box.
Entering 0 indicates that the Simulink software evaluates this block as a
continuous time block. If you have discrete blocks in your model, enter the
Fixed step size you entered in the Configuration Parameters dialog box.

Your Scope parameters dialog box looks like this:

4 Do one of the following:

• Click Apply to apply the changes to your model and leave the dialog
box open.
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• Click OK to apply the changes to your model and close the dialog box.

5 In the Scope window, point to the y-axis and right-click.

From the menu, click Axes Properties.

The Scope properties: axis 1 dialog box opens.

6 In the Y-min and Y-max text boxes enter the range for the y-axis in the
Scope window. For example, enter -2 and 2.

Your Scope axis dialog box looks like this:

7 Do one of the following:

• Click Apply to apply the changes to your model and leave the dialog
box open.

• Click OK to apply the changes to your model and close the dialog box.

Create Real-Time Application
You can create a real-time application in two modes, normal mode and
external mode.

Normal Mode
The basic setup for normal mode is minimal. In the simulation model dialog
box:

1 Select Simulation > Mode > Normal.

2 In your Real-Time Windows Target model, set values for the Sample Time
andMaximum Missed Ticks block parameters to prevent missed ticks.
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External Mode
In external mode, you must first create an executable target application. The
Simulink Coder code generation software creates C code from your Simulink
model, then the bundled C compiler compiles and links that C code into a
real-time application.

This procedure uses the Simulink model rtwin_model as an example, and
assumes you have loaded that model:

1 Enter parameters into the Configuration Parameters dialog box for use by
the Simulink Coder code generation software. See “Set External Mode Code
Generation Parameters” on page 3-14.

2 In the Simulink window, from the Code menu, point to C/C++ Code, and
then click Build Model.

The build process does the following:

• The Simulink Coder code generation software creates the C code source
files rtwin_model.c and rtwin_model.h.

• The build process creates the makefile rtwin_model.mk from the template
makefile rtwin.tmf.

• The build process creates the real-time application rtwin_model.rwd using
the makefile rtwin_model.mk created above. The file rtwin_model.rwd is
a binary file that we refer to as your real-time application. You can run the
real-time application with the Real-Time Windows Target kernel.

3 Connect your Simulink model to your real-time application. See “Set External
Mode Scope Parameters” on page 3-19.

After you create a real-time application, you can exit the MATLAB
environment, start the MATLAB environment again, and then connect and
run the executable without having to rebuild.

Set External Mode Scope Parameters
Simulink normal mode runs the simulation algorithm in Simulink and
accesses the external hardware using drivers running in Windows kernel
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mode. The Simulink block diagram is a graphical user interface to your
real-time application.

Simulink external mode connects your Simulink model to your real-time
application. This connection allows you to use the Simulink block diagram
as a graphical user interface as in normal mode.

After you have created a real-time application, you can enter scope parameters
for signal tracing with Simulink external mode:

1 In the Simulation window, and from the Simulation menu, click Model
Configuration Parameters.

2 Select the Code Generation > Real-Time Windows Target node.

The Real-Time Windows Target pane opens.

3 If the External mode check box is selected, your changes will affect the
real-time application.

TheMEX-file name label should have an entry of rtwinext. The MEX-file
rtwinext.mex* is supplied with the Real-Time Windows Target software
to work with Simulink external mode and support uploading signal data
and downloading parameter values.

The Real-Time Windows Target pane looks like this:
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4 Click OK.

5 In the Simulation window, click Code > External Mode Control Panel.

The External Mode Control Panel dialog box opens.

6 Click the Signal & Triggering button.

The External Signal & Triggering dialog box opens.

7 Select the Select all check box. From the Source list, choose manual.
From the Mode list, select normal.

The X under Signal selection indicates that a signal is tagged for data
collection, and T indicates that the signal is tagged as a trigger signal.

8 In the Duration field, enter the number of sample points in a data buffer.
For example, to specify a sample rate of 1000 samples/second and a stop
time of 10 seconds, enter

10000
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9 Select the Arm when connecting to target check box.

If you do not select this check box, data is not displayed in the Scope
window.

The External Signal & Triggering dialog box looks like this:

10 Do one of the following:

• Click Apply to apply the changes to your model and leave the dialog
box open.

• Click Close to apply the changes to your model and close the dialog box.

You must click the Apply or Close button on the External Signal &
Triggering dialog box for the changes you made to take effect.

Run Application from Simulink
After you build the real-time application, you can run your model in real time.

These procedures use the Simulink model rtwin_model as an example, and
assumes you have created a real-time application for that model.
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Normal Mode
In normal mode, the procedure is as follows:

1 Select Simulation > Mode > Normal.

2 Select Simulation > Run or click the Run button on the toolbar.

3 Do one of the following:

• Let the simulation run until it reaches the stop time.

• Select Stop.

The real-time simulation stops.

External Mode
In external mode, you run your real-time application to observe the behavior
of your model in real time with the generated code. The process of connecting
consists of

• Establishing a connection between your Simulink model and the kernel to
allow exchange of commands, parameters, and logged data.

• Running the application in real time.

The procedure is as follows:

1 Select Simulation > Mode > External.

2 Click Simulation > Connect To Target or click the Connect To Target

button on the toolbar.

The MATLAB Command Window displays the message

Model rtwin_model loaded

3 Click Simulation > Run or click the Run button on the toolbar.
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The Simulink software runs the execution and plots the signal data in the
Scope window.

In this example, the Scope window displays 1000 samples in 1 second,
increases the time offset, and then displays the samples for the next 1 second.

Note Transfer of data is less critical than calculating the signal outputs at
the selected sample interval. Therefore, data transfer runs at a lower priority
in the remaining CPU time after real-time application computations are
performed while waiting for another interrupt to trigger the next real-time
application update. The result may be a loss of data points displayed in the
Scope window.

4 Do one of the following:

• Let the execution run until it reaches the stop time.

• From the Simulation menu, click Stop Real-time Code.

The real-time application stops.

5 In the Simulation window, and from the Simulationmenu, click Disconnect
From Target.

6 Click Simulation > Mode > External.
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The MATLAB Command Window displays the message

Model rtwin_model unloaded

Run Application from MATLAB Command Line
You can use the MATLAB command-line interface as an alternative to using
the Simulink GUI. Enter commands directly in the MATLAB Command
Window or save them in a script file.

After you build the real-time application, you can run your model in real time.

These procedures use the Simulink model rtwin_model as an example, and
assumes you have created a real-time application for that model.

Normal Mode

1 In the MATLAB Command Window, type

set_param(gcs,'SimulationMode','normal')

The Simulink software changes to normal mode.

2 Type

set_param(gcs,'SimulationCommand','start')

The Simulink software starts running the real-time application.

3 Type

set_param(gcs,'SimulationCommand','stop')

The Simulink software stops the real-time application.

External Mode

1 In the MATLAB Command Window, type

set_param(gcs,'SimulationMode','external')
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The Simulink software changes to external mode.

2 Type

set_param(gcs,'SimulationCommand','connect')

The MATLAB environment loads the real-time application, connects it to the
Simulink block diagram, and displays the message

Model rtwin_model loaded

3 Type

set_param(gcs,'SimulationCommand','start')

The Simulink software starts running the real-time application.

4 Type

set_param(gcs,'SimulationCommand','stop')

The Simulink software stops the real-time application.
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Log Signals to MATLAB Workspace

In this section...

“Signal Logging to the Workspace” on page 3-27

“Set Scope Parameters for Logging to Workspace” on page 3-27

“Set External Mode Signal and Trigger Properties” on page 3-29

“Plot Signal Data Logged to Workspace” on page 3-32

Signal Logging to the Workspace
Logging signals to the workspace saves data to a variable in your MATLAB
base workspace. This process allows you to use MATLAB functions for data
analysis and MATLAB plotting functions for visualization. You can save data
to a variable during a simulation or during an execution.

If your model contains Outport blocks, you cannot save signal data in
Simulink external mode. Simulink supports signal logging with Outport
blocks in normal mode only, when Simulink runs the simulation algorithm.

Tip In external mode, do not enter or select parameters on the Data I/O tab
in the Configuration Parameters dialog box. Instead, add a Scope block to
your Simulink model and use it to log signal data.

Set Scope Parameters for Logging to Workspace
Data is saved to the MATLAB workspace through a Simulink Scope block.
Scope block parameters need to be set for data to be saved. After you create a
Simulink model and add a Scope block, you can enter the scope parameters for
signal logging to the MATLAB workspace. This procedure uses the Simulink
model rtwin_model as an example, and assumes you have already loaded
that model.
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Note If you entered the scope parameters for running a simulation, you may
want to look over this procedure, because the Scope parameters dialog box is
related to the External Signal and Triggering dialog box.

1 In the Simulink window, double-click the Scope block.

A Scope window opens.

2 Click the Parameters button on the toolbar.

A Scope Parameters dialog box opens.

3 Click the History tab.

4 Do one of the following:

• If you are running a simulation, select the Limit data points to last
check box, and enter the number of sample points to save.

• If you are running an execution, do not select the Limit data points to
last check box.

The Limit data points to last check box is related to the Duration
value in the External Signal and Triggering dialog box. The smaller of
either value limits the number of sample points saved to the MATLAB
workspace. When you are using Real-Time Windows Target software, use
the Duration value to set the number of sample points you save. To set
the Duration value, see the next section.

5 Select the Save data to workspace check box. In the Variable name
text box, enter the name of a MATLAB variable. The default name is
ScopeData.

6 From the Format list, choose Structure with time, Structure, or Array
(compatible with V2.0-2.2). For example, to save the sample times and
signal values at those times, choose Structure with time.

Your History pane looks like this:
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7 Do one of the following:

• Click Apply to apply the changes to your model and leave the dialog
box open.

• Click OK to apply the changes to your model and close the dialog box.

When you modify a value in the Scope parameters dialog box, you must
click the Apply or OK button for the changes to take effect, and you must
rebuild your real-time application before connecting and starting it. If you
do not rebuild, an error dialog box will open. If you do not click Apply, your
executable will run, but it will use the old settings.

The reason why you need to rebuild is because the model checksum
includes settings from the Scope block used for signal logging. If the
model checksum does not match the checksum in the generated code, the
real-time application cannot run. Rebuild your real-time application after
changing Scope parameters.

Set External Mode Signal and Trigger Properties
Data is saved to the MATLAB workspace through a Simulink Scope block.
Signal and triggering properties need to be set only when you are running
a real-time application. If you are running a normal mode simulation, you
can skip this procedure.
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After you create a Simulink model and add a Scope block, you can enter the
signal and triggering properties for logging to the MATLAB workspace. This
procedure uses the Simulink model rtwin_model as an example and assumes
you have already loaded that model:

1 In the Simulation window, click Code > External Mode Control Panel.

The External Mode Control Panel dialog box opens.

2 Click the Signal & Triggering button.

The External Signal & Triggering dialog box opens.

3 Click the Select all button. From the Source list, choose manual. From
the Mode list, choose normal.

The X under Signal selection designates that a signal has been tagged
for data collection, and T designates that the signal has been tagged as
a trigger signal.

4 In the Duration field, enter the number of sample points in a data buffer.
For example, if you have a sample rate of 1000 samples/second and a stop
time of 10 seconds, you could enter

10000

The Duration value is related to the Limit data points to last value
in the Scope parameters dialog box. The smaller of either value limits
the number of sample points saved to the MATLAB workspace. You
should not select the Limit data points to last check box; instead, use
the Duration value to set the number of sample points saved. To clear
the Limit data points to last check box, see “Set Scope Parameters for
Logging to Workspace” on page 3-27.

The Duration value specifies the number of contiguous points of data to be
collected in each buffer of data. You should enter a Duration value equal
to the total number of sample points that you need to collect rather than
relying on a series of buffers to be continuous.

If you enter a value less than the total number of sample points, you may
lose sample points during the time spent transferring values from the
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data buffer to the MATLAB workspace. The Real-Time Windows Target
software maintains point continuity only within one buffer. Between
buffers, because of transfer time, some samples will be omitted.

Also, you should set the time axis for Simulink Scope blocks equal to the
sample interval (in seconds) times the number of points in each data buffer.
This setting will display one buffer of data across the entire Simulink
Scope plot.

The External Signal & Triggering dialog box looks like this:

5 Do one of the following:

• Click Apply to apply the changes to your model and leave the dialog
box open.

• Click Close to apply the changes to your model and close the dialog box.

You must click the Apply or Close button on the External Signal &
Triggering dialog box for the changes you made to take effect.
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Plot Signal Data Logged to Workspace
You can use the MATLAB plotting functions for visualizing non-real-time
simulated data or real-time application data.

After running your real-time application and logging data to the MATLAB
workspace, you can plot the data. This procedure uses the Simulink model
rtwin_model as an example, and assumes you saved your data to the variable
ScopeData.

1 In the MATLAB Command Window, type

ScopeData

The MATLAB Command Window shows the structure of the variable
ScopeData. The variable ScopeData is a MATLAB structure containing
fields for the time vector, signal structure, and a string containing the
block name.

ScopeData =
time: [10000x1 double]

signals: [1x1 struct]
blockName: 'rtwin_model/Scope'

To list the contents of the structure signals, type

ScopeData.signals

The MATLAB Command Window shows the structure of the variable
ScopeData.signals. This structure contains one or more vectors of signal
data depending on the number of signal inputs to the Scope block.

ans =
values: [10000x1 double]

dimensions: 1
label: ''
title: []

plotStyle: 1

2 To plot the first 1000 points, type

plot(ScopeData.time(1:1000),ScopeData.signals.values(1:1000))
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The MATLAB environment plots the first 1000 samples from 0.0000 to
0.9990 second.

3 The variable ScopeData is not automatically saved to your hard disk. To
save the variable ScopeData, type

save ScopeData

The MATLAB environment saves the scope data to the file ScopeData.mat.
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Log Signals to File

In this section...

“Signal Logging to a File” on page 3-34

“Set Scope Parameters for Logging to File” on page 3-34

“Set External Mode Signal and Trigger Properties” on page 3-36

“Set External Mode Data Archiving Parameters” on page 3-38

“Plot Signal Data Logged to File” on page 3-40

Signal Logging to a File
Logging signals to a file saves data to a variable in your MATLAB workspace
and then saves that data to a MAT-file. This allows you to use MATLAB
functions for data analysis and MATLAB plotting functions for visualization.

If your model contains Outport blocks, you cannot save signal data in
Simulink external mode. Simulink supports signal logging to a file in normal
mode only, when Simulink runs the simulation algorithm.

Tip In external mode, do not enter or select parameters on the Data I/O tab
in the Configuration Parameters dialog box. Instead, add a Scope block to
your Simulink model and use it to log signal data for data archiving.

Set Scope Parameters for Logging to File
You save data to a file by first saving the data to the MATLAB workspace
through a Simulink Scope block. You need to set scope block parameters
for data to be saved.

After you create a Simulink model and add a Scope block, you can enter
the scope parameters for signal logging to a file. This procedure uses the
Simulink model rtwin_model as an example, and assumes you have already
loaded that model.
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Note If you entered the scope parameters for running a simulation, you
may want to look over this procedure, because the Scope parameters dialog
box is related to the External Signal & Triggering dialog box and the Data
Archiving dialog box.

1 In the Simulink window, double-click the Scope block.

A Scope window opens.

2 Click the Parameters button on the toolbar.

A Scope parameters dialog box opens.

3 Click the History tab.

4 Do one of the following:

• If you are running a simulation, you can select the Limit data points
to last check box, and enter the number of sample points to save.

• If you are running an execution, do not select the Limit data points to
last check box.

The Limit data points to last check box is related to the Duration value
in the External Signal & Triggering dialog box. The smaller of either value
limits the number of sample points saved to the MATLAB workspace. When
using Real-Time Windows Target software, you should use the Duration
value to set the number of sample points you save. To set the Duration
value, see “Set External Mode Signal and Trigger Properties” on page 3-36.

5 Select the Save data to workspace check box. In the Variable name
text box, enter the name of a MATLAB variable. The default name is
ScopeData.

The Scope parameters dialog box is related to the Data Archiving dialog
box. In the Scope parameters dialog box, you must select the Save data to
workspace check box to be able to save data to a file, for two reasons:

• The data is first transferred from the data buffer to the MATLAB
workspace before being written to a MAT-file.
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• The Variable name entered in the Scope parameters dialog box is the
same as the one in the MATLAB workspace and the MAT-file.

If you do not select the Save data to workspace check box, the MAT-files
for data logging will be created, but they will be empty.

6 From the Format list, choose either Structure with time, Structure, or
Array (compatible with Version 2.0 through Version 2.2). For example, to
save the sample times and signal values at those times, choose Structure
with time. Your History pane looks like this:

7 Do one of the following:

• Click Apply to apply the changes to your model and leave the dialog
box open.

• Click OK to apply the changes to your model and close the dialog box.

You must rebuild your real-time application before connecting and starting
the application with changed settings. If you do not rebuild after making
changes, an error will occur.

Set External Mode Signal and Trigger Properties
Data is saved to a file by first saving the data to the MATLAB workspace
through a Simulink Scope block. Signal and triggering properties need to be
set when running a real-time application.
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After you create a Simulink model and add a Scope block, you can enter the
signal and triggering properties for data logging to a file. This procedure
uses the Simulink model rtwin_model as an example, and assumes you have
already loaded that model:

1 In the Simulation window, click Code > External Mode Control Panel.

The External Mode Control Panel dialog box opens.

2 Click the Signal & Triggering button.

The External Signal & Triggering dialog box opens.

3 Click the Select all button. From the Source list, choose manual. From
the Mode list, choose normal.

The X under Signal selection designates that a signal has been tagged
for data collection, and T designates that the signal has been tagged as
a trigger signal.

4 In the Duration field, enter the number of sample points in a data buffer.
For example, if you have a sample rate of 1000 samples/second and a stop
time of 10 seconds, then enter

10000

The Duration value is related to the Limit data points to last value in
the Scope parameters dialog box. The smaller of either value limits the
number of sample points saved to the MATLAB workspace. You should not
select the Limit data points to last check box, and use the Duration
value to set the number of sample points saved.

The Duration value specifies the number of contiguous points of data to be
collected in each buffer of data. You should enter a Duration value equal
to the total number of sample points you need to collect for a run. If you
enter a value less than the total number of sample points, you may lose
sample points due to the time spent transferring values from the data
buffer to the MATLAB workspace.

You should also set the time axis for Simulink Scope blocks equal to the
sample interval (in seconds) times the number of points in each data buffer.
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This setting will display one buffer of data across the entire Simulink
Scope plot.

The External Signal & Triggering dialog box looks like this:

5 Do one of the following:

• Click Apply to apply the changes to your model and leave the dialog
box open.

• Click Close to apply the changes to your model and close the dialog box.

You must click the Apply or Close button on the External Signal &
Triggering dialog box for the changes you made to take effect, but you do
not have to rebuild your real-time application.

Set External Mode Data Archiving Parameters
The Data Archiving dialog box is related to the Scope parameters dialog
box. In the Scope parameters dialog box, you must select the Save data to
workspace check box to be able to save data to a file, for two reasons:

• The data is first transferred from the scope data buffer to the MATLAB
workspace before being written to a MAT-file.
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• The Variable name entered in the Scope parameters dialog box is the
same as the one in the MATLAB workspace and the MAT-file. Enabling
the data to be saved enables a variable named with the Variable name
parameter to be saved to a MAT-file.

If you do not select the Save data to workspace check box in the Scope
parameters dialog box, the MAT-files for data logging will be created, but
they will be empty.

After you create a Simulink model, you can enter the Data Archiving
Parameters for data logging to a file:

1 In the Simulation window, click Code > External Mode Control Panel.

The External Mode Control Panel dialog box opens.

2 Click the Data Archiving button.

The External Data Archiving dialog box opens. This dialog box allows you
to specify data archiving options.

3 Select the Enable archiving check box.

4 In the Directory text box, enter the path to a folder on your disk. For
example, if your MATLAB working folder is named mwd, enter

c:\mwd

5 In the File text box, enter the file name prefix for the data files to be
saved. For example, enter

data

The MATLAB environment names the files data_0.mat, data_1.mat, etc.
The number of files equals the total sample points. For example, if you set
Duration to Total sample points, then only one file is created.

6 Select the Append file suffix to variable names check box.

Within each MAT-file, a variable is saved with the same name you entered
in the Variable name text box (History pane on the Scope parameters
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dialog box). By selecting the Append file suffix to variable names check
box, the same suffix that is added to the MAT-file is added to the variable
name. For example, if you entered the variable name ScopeData, then
within the file data_0.mat will be a variable ScopeData_0.

Your External Data Archiving dialog box looks like this:

7 Click the Close button.

The parameters you entered are applied to your model.

There is no Apply button with this dialog box. You must click the Close
button for the changes you make to take effect.

Plot Signal Data Logged to File
You can use the MATLAB plotting functions for visualization of your
non-real-time simulated data or your real-time executed data.

After running your real-time application and logging data to a file, you can
plot the data. This procedure uses the Simulink model rtwin_model as an
example, and assumes you saved your data to the variable ScopeData:

1 In the MATLAB Command Window, type

ScopeData
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The MATLAB Command Window shows the structure of the variable
ScopeData. The variable ScopeData is a MATLAB structure containing the
fields time vector, signal structure, and a string containing the block name.

ScopeData =
time: [10000x1 double]

signals: [1x1 struct]
blockName: 'rtwin_model/Scope'

2 To list the MAT-files saved to your disk, type

dir *.mat

The MATLAB Command Window shows the MAT-files in your current
working folder.

ScopeData.mat

3 To clear the MATLAB workspace and load the scope data, type

clear
load ScopeData
who

The MATLAB Command Window displays:

Your variables are:
ScopeData

4 To plot the first 1000 points, type

plot(ScopeData.time(1:1000), ScopeData_0.signals.values(1:1000))

The MATLAB environment plots the first 1000 samples from 0.0000 to
0.9990 second.
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Tune Parameters

In this section...

“Tune Block Parameters and MATLAB Variables” on page 3-43

“Change Model Parameters” on page 3-44

Tune Block Parameters and MATLAB Variables
In Simulink normal mode, only the I/O drivers run in the kernel. Simulink
itself manages the blocks and their parameters. This means that in normal
mode, block parameters can be tuned just as in a non-real-time model.

Simulink external mode connects your Simulink model to your real-time
application. The block diagram becomes a graphical user interface to the
real-time application You can change parameter values while running the
real-time application by changing the values in

• Block parameters — Change block parameters by changing the values in
the dialog boxes associated with the Simulink blocks. Once you change
a value, and click OK, the new value is downloaded to the real-time
application.

• MATLAB variables — Change MATLAB variables by entering the changes
through the MATLAB command line, and then press Ctrl+D for the
changes to be downloaded to your executable. An alternative method to
download parameters is to click Simulation > Update Diagram in your
Simulink window. Simply changing the value of the MATLAB variable at
the MATLAB command line does not tell the Simulink software that the
value has changed.

Simulink external mode also supports side-effect functions. For example,
given an expression in a Gain block of 2*a+b, the expression is evaluated and
the resulting value is exported to the real-time application during execution.

When a parameter in a Simulink model is changed, the communication
module rtwinext.mex* transfers the data to the external real-time
application and changes the model parameters. Only the parameters that do
not result in model structure modification can be changed. If the structure
is modified, you must recompile the model. Model structure changes are
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detected automatically using model checksum and reported to the MATLAB
Command Window to avoid conflicts.

Change Model Parameters
After you start running your real-time application, you can open Simulink
blocks, change parameter values, and observe the changes to the signals. In
normal mode, Simulink transfers the new value to the real-time driver. In
external mode, Simulink transfers the new value to the real-time application.

The following procedure uses the Simulink model rtwin_model as an example.
It assumes you have created a real-time application and are executing it.

1 From the Simulation menu, click Run.

The real-time execution starts running and signal data is displayed in the
Scope window.

2 From the Simulink block diagram, double-click the Transfer Function block.

The Block Parameters: Transfer Fcn dialog box opens.

3 In the Denominator field, change 70 to 30. Click OK.

The effect of changing a block parameter is shown in the Scope window.
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4

Boards, Blocks, and Drivers

Real-Time Windows Target software includes driver blocks for more than 200
I/O boards. These driver blocks connect the physical world to your real-time
application.

• “Use I/O Boards” on page 4-2

• “Use I/O Driver Blocks” on page 4-8

• “Use Analog I/O Drivers” on page 4-13

• “Use Vector CAN Drivers” on page 4-18



4 Boards, Blocks, and Drivers

Use I/O Boards
Typically I/O boards are preset from the factory for certain base addresses,
voltage levels, and unipolar or bipolar modes of operation. Boards often
include switches or jumpers that allow you to change many of these initial
settings. For information about setting up and installing an I/O board, read
the board manufacturer’s documentation.

For an online list of I/O boards that Real-Time Windows Target software
supports, see Supported I/O Boards.

In this section...

“Install and Configure I/O Boards and Drivers” on page 4-2

“ISA Bus Board” on page 4-5

“PCI Bus Board” on page 4-5

“PC/104 Board” on page 4-6

“Compact PCI Board” on page 4-6

“PCMCIA Board” on page 4-6

Install and Configure I/O Boards and Drivers
A Real-Time Windows Target model connects to a board by including an I/O
driver block. This block provides an interface to the board’s device driver and
the board-specific settings. The device drivers included with the Real-Time
Windows Target software usually provide the same flexibility of settings
offered by the board manufacturer. You can enter I/O board settings by using
the I/O Block Parameters dialog box; setting jumpers and switches on the
board; or both. The three types of board settings are:

• Software selectable — Specify the desired settings in the I/O Block
Parameters dialog box. The driver writes the settings you specify to the
board. Examples include A/D gain inputs and selecting unipolar or bipolar
D/A outputs.

• Hardware selectable and software readable — Specify the desired
settings by configuring jumpers or switches on the board. The driver reads
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the settings you selected and displays them in the I/O Block Parameters
dialog box.

• Hardware selectable, but not software readable — Set jumpers or
switches on the physical board, and then enter the same settings in the I/O
Block Parameters dialog box. These entries must match the hardware
jumpers or switches you set on the board. Use this type of setting when the
board manufacturer does not provide a means for the I/O driver to write
or read the board settings. Examples include base address, D/A gain, and
differential or single-ended A/D inputs.

You can configure a Real-Time Windows Target model to use an I/O board
whether or not the board exists in the computer, but you will not be able to
run the model until the board is installed with its jumpers and switches set.
Details of installation and configuration depend on the data transfer direction
and the specific board, but are similar in most cases. Details for various types
of boards and drivers appear later in this topic.

The following instructions use the HUMUSOFT® AD512 I/O board as an
example, configure the board for analog input, and assume that you have
physically configured and installed the board in your computer before you add
its driver to your model. Customize the steps to achieve the results you need.

To install and configure an I/O board and its driver,

1 Install the board in the computer, setting jumpers or switches according to
the board documentation.

2 In the model window, choose View > Library Browser to display the
Simulink Library Browser.

3 Drag an Analog Input I/O driver block into your model from the Real-Time
Windows Target library.

4 Double-click the driver block in the model.

The I/O Block Parameters dialog box opens.

5 Click Install new board. From the list that appears, point to a
manufacturer, then select a board type. For example, point to Humusoft,
then click AD512.
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The I/O board dialog box opens. The name of this dialog box depends on
which I/O board you selected.

6 Select one of the following, as required by the board type:

• For an ISA bus board, enter a hexadecimal base address. This value
must match the base address jumpers or switches set on the physical
board. For example, to enter a base address of 0x300, in the Address
box type

300

You can also select the base address by checking boxes A9 through A3.

• For a PCI bus board, enter the logical device number in the Device
order box or check Auto-detect.

7 Set the other required block parameters using the I/O Block Parameters
dialog box.

8 Click Test.

The Real-Time Windows Target kernel tries to connect to the selected
board, and if it does so without an error, displays a message indicating
that it found the board.

9 Click OK on the message box, and again on the I/O Block Parameters
dialog box.

The I/O Block Parameters dialog box closes, and the parameter values are
included in your Simulink model.

Multiple Boards of Identical Type
When multiple boards of identical type exist, you must execute the complete
installation sequence for each board, just as you would if the boards were of
different types. Thus, two identical PCI boards result in two entries in the
list of installed boards. The entries differ only in the logical device number
shown in the Device order box for each board.

Autodetect Multiple Boards. The Autodetect feature cannot be used to
locate multiple boards of the same type. You must specify their logical device
numbers manually.
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Multiple Driver Blocks for One Board
Once you have used the I/O Block Parameters dialog box to add a board and
configure its driver, you can add additional I/O driver blocks that connect
to the same board from other locations in the model. To do this, drag the
required driver block into the model, open its I/O Block Parameters dialog
box, and choose the board from the list of installed boards.

Scope of Driver Block Parameters. I/O driver blocks that use a given
board share identical parameters. You need to specify these parameters
only once, when you first add the board and configure its driver. If you
subsequently change a parameter in a driver block connected to a board, the
same change occurs in the other driver blocks connected to that board.

ISA Bus Board
Most ISA bus I/O boards are preset with a base address of 0x300. If you are
using multiple I/O boards or other boards (for example, network cards) that
already use the address 0x300, you must set your board with another base
address.

In the I/O board dialog box, enter the same base address that you set on the
physical board. You open the I/O board dialog box from an I/O driver Block
Parameters dialog box.

PCI Bus Board
You do not have to set a base address for a PCI board. The plug-and-play
feature of the Windows operating system assigns a PCI slot number and
logical device number. You can enter the logical device number in the Device
order box, or you can let the driver determine the device number for you. The
Device order box is in the I/O board dialog box, which you can open from an
I/O driver Block Parameters dialog box.

Before you use a PCI or PCMCIA board, you should install the drivers
supplied by the board manufacturer. The Real-Time Windows Target
software does not use these manufacturer-supplied drivers. However, they
sometimes initiate the plug-and-play recognition of the board. Without these
drivers installed, the board might be invisible to your computer and to the
Real-Time Windows Target software.
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Write PCI Bus Board Drivers
Real-Time Windows Target applications cannot use Windows DLLs and
kernel-mode drivers, which are not suitable for real-time operation. The
device drivers supported by the Real-Time Windows Target software are
listed at Supported I/O Boards. If no driver is listed for the board that you
want to use, you may be able to write a custom device driver.

A user-written custom device driver must program the board directly at the
register level. All supported Real-Time Windows Target drivers use this
technique. The Real-Time Windows Target software supports I/O mapped
board registers for custom device drivers. The Real-Time Windows Target
software does not support memory-mapped board registers for custom device
drivers.

If you want to use an unsupported board that you believe should be supported,
contact MathWorks Technical Support.

PC/104 Board
Most PC/104 bus I/O boards are preset with a base address of 0x300. If you
are using multiple I/O boards or other boards (for example, network cards)
that already use the address 0x300, you must set your board with another
base address.

In the I/O board dialog box, enter the same base address that you set on the
physical board. You open the I/O board dialog box from an I/O driver Block
Parameters dialog box.

Compact PCI Board
Using a compact PCI board (PXI®, PXI Express) requires you to use a compact
PC (industrial PC). In addition, you need to install the Windows operating
system, the MATLAB environment, Simulink software, and Real-Time
Windows Target software on the compact PC.

PCMCIA Board
The plug-and-play feature of the Windows operating system assigns a base
address automatically. You can enter this address in the I/O board dialog box,
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or you can let the driver determine the address for you. You open the I/O
board dialog box from an I/O driver Block Parameters dialog box.

Before you use a PCI or PCMCIA board, install the drivers supplied by the
board manufacturer. Real-Time Windows Target software does not use
these manufacturer-supplied drivers. However, they sometimes initiate the
plug-and-play recognition of the board. Without these drivers installed, the
board might be invisible to your computer and to the Real-Time Windows
Target software.
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Use I/O Driver Blocks
Real-Time Windows Target I/O driver blocks allow you to select and connect
specific analog channels and digital lines to your Simulink model through
I/O driver blocks. These blocks provide an interface to your physical I/O
boards and your real-time application. They enable the C code created by
Simulink Coder code generation software to map block diagram signals to the
corresponding I/O channels. All I/O blocks support all applicable Simulink
data types.

You can have multiple I/O blocks associated with each type of I/O board. For
example, you can have one Analog Input block for channels 1 to 4 and another
block for channels 5 to 8. Each I/O block in a model specifies its own block
configuration parameters, which apply only to that instance of that block.

The capability of an I/O driver block is available only if the corresponding I/O
hardware device supports that capability. For example, data-oriented devices
like Serial Port and File support Packet and Stream I/O blocks. However,
data acquisition devices do not support the Packet and Stream I/O blocks.

The Real-Time Windows Target Library provides blocks that you can use with
supported I/O boards. You can also create your own I/O blocks to work with
Real-Time Windows Target software. See “Custom I/O Driver Basics” on
page A-2 for details.

In this section...

“View Real-Time Windows Target Library” on page 4-8

“Route Signals from an I/O Block” on page 4-9

“Configure Channel Selection” on page 4-10

View Real-Time Windows Target Library
I/O driver blocks are available in the Real-Time Windows Target Library. To
view this library from the MATLAB Command Window, type:

rtwinlib

To view the Real-Time Windows Target Library from a model:
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1 In the model window, choose View > Library Browser.

The Simulink Library Browser opens. The left pane shows a hierarchy of
libraries and categories, with the Simulink library at the top. The right
pane shows the blocks available in the category selected on the left.

2 In the left column, double-click Real-Time Windows Target.

The Real-Time Windows Target library opens.

You can add an I/O block in the library to your Simulink model by dragging
it from the library to the model. After you add the block, connect it to
your model as you would any other block, and provide block configuration
parameter values.

Route Signals from an I/O Block
I/O driver blocks output multiple signals as a vector instead of individual
channels or lines. To connect the individual channels and lines to parts of
your Simulink model, you need to separate the vector with a Demux block.

After you add and configure an I/O driver block in your Simulink model, you
can separate and connect the output signals from the blocks:

1 In the Simulink window, choose View > Library Browser.

The Simulink Library Browser opens.

2 In the Simulink library, click Signal Routing. From the list in the right
pane, click and drag Demux to your Simulink model.

3 Double-click the Demux block. The Block Parameters: Demux dialog box
opens. Enter the number of lines leaving the Demux block. For example, if
you entered three channels in the Analog Input driver block, enter 3 in the
Number of outputs box.

4 Click OK.

5 Connect the Analog Input block to the Demux block input.

6 Connect each of the Demux block output lines to the input of other blocks.
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7 In the Simulink window, click Display > Signals & Ports > Wide
Nonscalar Lines.

8 Click Display > Signals & Ports > Signal Dimensions.

Note In this example, inputs 1 and 2 are not connected, but they could be
connected to other Simulink blocks.

Configure Channel Selection
For a better understanding of how to specify device settings when using
both analog and digital signals, this section uses the Keithley® Metrabyte™
DAS-1601 I/O board as an example. The following is a specification summary
of the DAS-1601 board:

• Analog input (A/D) — 16 single-ended or 8 differential analog inputs
(12-bit), polarity is switch configured as either unipolar (0 to 10 volts) or
bipolar (± 10 volts). Gain is software configured to 1, 10, 100, and 500.

• Digital input — Four unidirectional digital inputs

• Analog output (D/A) — Two analog outputs (12-bit). Gain is switch
configured as 0 to 5 volts, 0 to 10 volts, ± 5 volts, or ± 10 volts

• Digital output — Four unidirectional digital outputs

• Base address — Switch configured base address

This section explores different configurations for input signals.

Once an Analog Input block has been placed in the model and the I/O board
selected and configured, you can set up the Analog Input block to handle
input signals.

Single analog input — The most basic case is for a single analog input
signal that will be physically connected to the first analog input channel on
the board. In the Block Parameter: Analog Input dialog box, and the Input
channels box, enter

1 or [1]
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The use of brackets is optional for a single input.

Input vector with differential analog — Analog channels are numbered
starting with channel 1 and continue until you reach a number corresponding
to the maximum number of analog signals supported by the I/O board.

In the case of the DAS-1601, when configured as differential inputs, eight
analog channels are supported. The analog input lines are numbered 1
through 8. The complete input vector is

[1 2 3 4 5 6 7 8] or [1:8]

If you want to use the first four differential analog channels, enter

[1 2 3 4]

Input vector with single-ended analog — Now, assume your DAS-1601
board is configured to be single-ended analog input. In this case, 16 analog
input channels are supported. The complete input vector is

[1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16] or [1:16]

To use the first four single-ended analog input channels, enter

[1 2 3 4] or [1:4]

The next figure shows the resulting block diagram.

Do not specify more channels than you actually use in your block diagram.
This results in additional overhead for the processor with A/D or D/A
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conversions. In this case, for example, even though some channels are not
actually used in the block diagram, these channels are still converted.

You could attach terminator blocks to channels 4 and 5 inside your block
diagram after passing the Analog Input block vector in to a Demux block.
Adding terminator blocks provides you with graphical information in your
block diagram to clearly indicate which channels you connected and which are
available. The penalty is that even the terminated channels are converted,
adding some computational overhead.

The next figure shows the block implementation.

Depending on the board and the number of channels used, I/O conversion time
can affect the maximum sample rate that can be achieved on your system.
Rather than converting unused channels, specify only the set of channels that
are actually required by your model.
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Use Analog I/O Drivers
Control systems have unique requirements for I/O devices used with
Real-Time Windows Target applications. For information about writing
custom I/O device drivers to work with Real-Time Windows Target
applications, see “Custom I/O Driver Basics” on page A-2.

In this section...

“Configure I/O Driver Characteristics” on page 4-13

“Normalize Scaling for Analog Inputs” on page 4-14

Configure I/O Driver Characteristics
Real-Time Windows Target applications use off-the-shelf I/O boards provided
by many hardware vendors. These boards are often used for data acquisition
independently of Real-Time Windows Target software. In such environments,
board manufacturers usually provide their own I/O device drivers for data
acquisition purposes. This use differs significantly from the behavior of
drivers provided with Real-Time Windows Target software.

In data acquisition applications, data is often collected in a burst or frame
consisting of many points, possibly 1,000 or more. The burst of data becomes
available once the final point is available. This approach is not suitable for
automatic control applications, because it results in unacceptable latency
for most of the data points.

In contrast, drivers used by Real-Time Windows Target applications capture
a single data point at each sample interval. Considerable effort is made to
minimize the latency between collecting a data point and using the data in
the control system algorithm. This is why a board might specify a maximum
sample rate (for data acquisition) higher than the rates achievable by
Real-Time Windows Target applications. For data acquisition, such boards
usually acquire data in bursts and not in the point-by-point fashion required
by control systems.
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Normalize Scaling for Analog Inputs
Real-Time Windows Target software allows you to normalize I/O signals
internal to the block diagram. Generally, inputs represent real-world values
such as angular velocity, position, temperature, pressure, and so on. This
ability to choose normalized signals allows you to

• Apply your own scale factors

• Work with meaningful units without having to convert from voltages

When using an Analog Input block, you select the range of the external
voltages that are received by the board, and you choose the block output
signal. For example, the voltage range could be set to 0 to +5 V, and the
block output signal could be chosen as Normalized unipolar, Normalized
bipolar, Volts, or Raw.

If you prefer to work with units of voltage within your Simulink block
diagram, you can choose Volts.

If you prefer to apply your own scaling factor, you can choose Normalized
unipolar or Normalized bipolar, add a Gain block, and add an offset to
convert to a meaningful value in your model.

If you prefer unrounded integer values from the analog-to-digital conversion
process, you can choose Raw.

0 to +5 Volts and Normalized Bipolar
From the Input range list, choose 0 to +5 V, and from the Block output
signal list, choose Normalized bipolar. This example converts a
normalized bipolar value to volts, but you could also easily convert directly
to another parameter in your model.

0 to 5 volts --> ([-1 to 1] normalized + 1) * 2.5

In your block diagram, you can do this as follows.
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0 to +5 Volts and Normalized Unipolar
From the Input range list, choose 0 to +5 V, and from the Block output
signal list, choose Normalized unipolar. This example converts a
normalized unipolar value to volts, but you could also easily convert directly
to another parameter in your model.

0 to 5 volts --> ([0 to 1] normalized * 5.0

In your block diagram, you can do this as follows.

-10 to +10 Volts and Normalized Bipolar
From the Input range list, choose -10 to +10 V, and from the Block
output signal list, choose Normalized bipolar. This example converts a
normalized bipolar value to volts, but you could also easily convert directly
to another parameter in your model.

-10 to 10 volts --> [-1 to +1] normalized * 10

In your block diagram, you can do this as follows.
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-10 to +10 Volts and Normalized Unipolar
From the Input range list, choose -10 to +10 V, and from the Block
output signal list, choose Normalized unipolar. This example converts a
normalized bipolar value to volts, but you could also easily convert directly
to another parameter in your model.

-10 to 10 volts --> ([0 to 1] normalized - 0.5) * 20

In your block diagram, do this as follows.

Normalize Scaling for Analog Outputs
Analog outputs are treated in an equivalent manner to analog inputs.

If the voltage range on the D/A converter is set to 0 to +5 volts, and the
Block input signal is chosen as Normalized bipolar, then a Simulink
signal of amplitude -1 results in an output voltage of 0 volts. Similarly, a
Simulink signal of amplitude +1 results in an output voltage of +5 volts.

A voltage range on the D/A converter is set to -10 to +10 volts, and the
Block input signal is chosen as Normalized bipolar, then a Simulink
signal of amplitude -1 results in an output voltage of -10 volts. Similarly, a
Simulink signal of amplitude +1 results in an output voltage of +10 volts.
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This may require that you adjust your signal amplitudes using a Gain block,
Constant block, and Summer block depending on the selected voltage range.
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Use Vector CAN Drivers
Before you can use the Vector Informatik CAN devices, you must install the
drivers for them.

1 Install the Vector CAN devices. See the Vector Informatik GmbH
documentation for installation instructions for hardware devices such as
CANcaseXL, CANboardXL, and CANcardXL, drivers, support libraries,
and so on.

2 Install the Vector XL driver library for the Windows XP, Windows Vista, or
Windows 7 operating systems. If you do not have this library, download it
from the Vector Informatik GmbH web site:

https://www.vector.com/vi_downloadcenter_en.html

3 Install the driver file.

4 Copy the vxlapi.dll file into the Windows system root\system32 folder.

5 Use the Vector software to assign physical CAN channels to an application.
When specifying the name for the Real-Time Windows Target application,
use the string MATLAB.
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5

Troubleshooting

Solutions have been worked out for some common errors and problems that
can occur when you are using Real-Time Windows Target software.

• “Failure to Connect to Target” on page 5-2

• “Scope Output Delayed or Missing” on page 5-4

• “Plots Not Visible in Simulink Scope Block” on page 5-5

• “S-Functions Using Math Functions” on page 5-6

• “Building Older Models” on page 5-7
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Failure to Connect to Target
Possible Problem — When trying to run a model, the Simulation Errors dialog
box displays:

Error occurred while executing External Mode MEX-file

'rtwinext': Incorrect version

Solution — This indicates that the Real-Time Windows Target kernel may
be out of date. Type rtwho at the MATLAB prompt. If you see a message
like this, install the current version:

Incorrect kernel version is installed.
Use 'rtwintgt -setup' to install the correct version.

Possible Problem — When trying to connect to the target, the Simulation
Errors dialog box displays:

Checksum mismatch. Target code needs to be rebuilt.

Solution — This indicates that the model structure has changed since the last
time code was generated. You must rebuild the real-time application. If your
model fails to build, delete .mk and .obj files from the Simulink Coder project
folder, and then select Build from the Tools menu.

Possible Problem — When trying to connect to the target, the Simulink
Diagnostic dialog box displays

External mode MEX-file "win_tgt" does not exist or is not on the

MATLAB path.

Solution — Versions 1.0 and 1.5 of the Real-Time Windows Target software
used the MEX-file win_tgt. For Version 2.2 and later, the MEX-file name was
changed to rtwinext. If you create a new Simulink model, the new filename
is entered. If you have a Simulink model where you used Version 1.0 or 1.5,
you need to change the filename using the following procedure:

1 In the Simulink window, from the Code menu, click External Mode
Control Panel.
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2 In the External Mode Control Panel dialog box, click the Target interface
button.

3 In the MEX-file for external mode text box, enter

rtwinext

4 Click OK.
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Scope Output Delayed or Missing
During an external mode run, you may notice either slow updates of Scope
blocks or a complete failure to plot data in Scope blocks. This could indicate
that the real-time application sample time is near the lower threshold for
your hardware.

Note The sample time is set in the Fixed step size (fundamental sample
time) field in the Configuration Parameters Solver pane, which appears
when Type is set to Fixed-step.

Plotting data has a lower priority than executing the application, so a small
sample time may allow the application to run but leave insufficient resources
for plotting. If the sample time is so small that the application itself cannot
run, an error message is displayed and real-time execution is terminated.

To check the sample time, select a larger sample time for your application.
You should also change the sample time of any I/O drivers to be the same as
the new application sample time, or an integer multiple of that time. Then
rebuild the model, connect to the target, and restart the real-time application.

As required, iterate changing the application sample time until scope output
appears. For example, start with a sample time of 0.01 second, and confirm
that your system runs and plots are displayed. Then decrease the sample
time until you can both display scopes and meet your accuracy and response
time requirements. You must update the I/O driver sample time and rebuild
the application after changing the application sample time.
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Plots Not Visible in Simulink Scope Block
Prior to an external mode run, you must specify the following for data to plot
in a Simulink Scope block:

1 Select Simulation > Mode > External.

2 Click the Connect To Target button on the toolbar.

3 Select one or more signals for capture (designated with "X") in the External
Signal & Triggering dialog box from the External Mode Control Panel.

4 Set Duration * Fixed Step Size close to or less than the X range in the
Scope block

5 Select required mode (one-shot or normal)

6 Configure signal levels to allow triggering

7 Set Y range on Simulink Scope block axes to large enough to span the
signal amplitude

8 Set X range to large enough to provide required time resolution

9 Set Arm when connect to target in the External Signal & Triggering
dialog box or Arm Trigger in the External Mode Control Panel.

10 Click the Run button on the toolbar.

If you cannot see signals plotted in your Simulink Scope blocks after carrying
out these steps, your system might have too little CPU time available between
sample intervals to transfer data back to MATLAB, where the plotting is
performed. To test for this condition, run one of the example models or run
your model at a significantly slower sample rate.
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S-Functions Using Math Functions
Possible problem — When you create your own S-functions that include math
functions, the S-functions compile, but you cannot build the application.

Solution — Add the Real-Time Windows Target header to your S-function.
For example, add

#include<math.h>
#include"rtwintgt.h"

The header #include<math.h> must precede the header
#include"rtwintgt.h".
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Building Older Models
If you are building an older model with Real-Time Windows Target software,
you might get a message like the following:

"Simulink Coder utilizes device specific information (e.g.,

microprocessor word sizes) to reproduce a bit true representation

of the diagram. This information is not specified in this model.

If you continue, Simulink Coder will use a 32-bit generic

target setting."

This is simply a warning, and you can ignore the message. To eliminate this
message, you can use the rtwinconfigset command, as follows:

rtwinconfigset('<model_name>')
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A Custom I/O Driver Blocks

Custom I/O Driver Basics

In this section...

“Supported C Functions” on page A-2

“Unsupported C Functions” on page A-3

“Incompatibility with Win32 API Calls” on page A-4

“I/O Register Access from S-Functions Limitation” on page A-4

You can write custom I/O device drivers to work with Real-Time Windows
Target applications.

Note Do not use Analog Input, Analog Output, Digital Input, or Digital
Output drivers as a starting point for creating custom device drivers.

Supported C Functions
You can use ANSI C functions that do not use the Windows operating system
in your custom blocks or I/O drivers. The following includes a partial list of
supported functions:

• Console I/O — printf

The printf function sends output to the MATLAB Command Window
when it is called from the real-time application.

• Data conversion — abs, atof, atoi, atol, itoa, labs, ltoa, strtod,
strtol, strtoul, ultoa

• Memory allocation — calloc, free, malloc

Memory allocation is not an operation that can be done in real time.
To work with a Real-Time Windows Target application, memory
management must occur before real-time simulation begins. Simulation
switches into real-time after mdlStart, so you can allocate memory in
mdlInitializeSizes or mdlStart. You cannot allocate memory in any
function after mdlStart, such as mdlOutputs or mdlUpdate.
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• Memory manipulation— _memccpy, memcpy, memchr, memcmp, _memicmp,
memmove, memset

• String manipulation — strcat, strchr, strcmp, strcpy, strcspn,
_strdup, _stricmp, strlen, _strlwr, strncat, strncmp, strncpy,
_strnset, strpbrk, strrchr, _strrev, _strset, strspn, strstr, strtok,
strupr

• Mathematical — acos, asin, atan, atan2, ceil, cos, cosh, div, exp,
fabs, floor, fmod, frexp, ldexp, ldiv, log, log10, max, min, modf, pow,
rand, sin, sinh, sqrt, srand, tan, tanh, uldiv

• Character class tests and conversion — isalnum, isalpha, _isascii,
iscntrl, isdigit, isgraph, islower, isprint, ispunct, isspace,
isupper, isxdigit, isxupper, isxlower, _toascii, tolower, toupper

• Searching and sorting — bsearch, qsort

• Dummy functions — exit, fprintf

Unsupported C Functions
If you create your own custom I/O driver blocks, you should use only C
functions supported by Real-Time Windows Target software. Functions that
use the Windows operating system are not supported by Real-Time Windows
Target. This includes functions from vendor-supplied driver libraries for
Windows, which are also not supported.

The following list includes many, but not all, of the unsupported functions:

• File I/O — fopen, freopen, fclose, fread, fwrite, fputs, fputc, fgets,
fgetc, gets, getc, getchar, puts, putc, putchar, fflush, setbuf, setvbuf

• Console I/O— fprintf, sprintf, vfprintf, vprintf, vsprintf, fscanf,
scanf, sscanf

• Process management— spawn, exit, abort, atexit

• Signals and exceptions — signal, longimp, raise

• Time functions — clock, time, difftime, asctime, ctime, difftime,
gmtime, localtime, mktime, strftime

• Win32 API functions— No Windows API functions are supported.
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Incompatibility with Win32 API Calls
The Real-Time Windows Target kernel intercepts the interrupt from the
system clock. It then reprograms the system clock to operate at a higher
frequency for running your real-time application. At the original clock
frequency, it sends an interrupt to the Windows operating system to allow
Windows based applications or any software using the Win32 API to run.

As a result, software that uses the Win32 API cannot be executed as
a component of your real-time application. Software you use to write
I/O drivers must not make calls to the Win32 API.

I/O Register Access from S-Functions Limitation
Windows operating system drivers can access I/O registers only from the
real-time kernel and not from the Simulink software. To prevent drivers
from attempting to access I/O registers from Simulink S-functions, enter code
fragments like the following:

#ifndef MATLAB_MEX_FILE
/* we are in RTWin kernel, do board I/O */
#else
/* we are in Simulink, don't do board I/O */
#endif
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